Cisco的静态、动态nat和端口复用配置

(..•˘_˘•..) 版权声明:转载原创文章请以超链接形式请注明原文章出处,尊重作者,尊重原创! (..•˘_˘•..)某些网站的小编真的是眼瞎! 转载注明出处!求求你了!

网络拓扑图:

思科nat网络拓扑图

注意:以下为静态NAT配置!

路由器0配置:

Router>enable
Router#configure terminal
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/0
Router(config-if)#ip add 11.0.0.1 255.255.255.0
Router(config-if)#clock rate 56000
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 11.0.0.2
Router(config)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#int s0/1/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat inside source static 192.168.1.2 11.0.0.3
Router(config)#exit
Router#write

路由器1配置:

Router>enable
Router#configure terminal
Router(config)#int s0/1/0
Router(config-if)#ip add 11.0.0.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/1
Router(config-if)#ip add 12.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Router#write

路由器2配置:

Router>enable
Router#configure terminal
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/0
Router(config-if)#ip add 12.0.0.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.1
Router(config)#exit
Router#write 

注意:以下为动态NAT配置!(拓扑图相同)

路由器0配置:

Router>enable
Router#configure terminal
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/0
Router(config-if)#ip add 11.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 11.0.0.2
Router(config)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#int s0/1/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip nat pool poolname 11.0.0.4 11.0.0.7 netmask 255.255.255.0
Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#ip nat inside source list 1 pool poolname

路由器1配置:

Router>enable
Router#configure terminal
Router(config)#int s0/1/0
Router(config-if)#ip add 11.0.0.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/1
Router(config-if)#ip add 12.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Router#write 

路由器2配置:

Router>enable
Router#configure terminal
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int s0/1/0
Router(config-if)#ip add 12.0.0.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 12.0.0.1
Router(config)#exit
Router#write

注意:以下是nat端口复用的配置!

网络拓扑图:

思科nat端口复用拓扑图

路由器0配置:

Router>enable
Router#configure terminal
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int f0/1
Router(config-if)#ip add 11.0.0.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#int f0/1
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet0/1
Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#ip nat inside source list 1 interface f0/1 overload
Router(config)#exit
Router#write 

注意:动态nat和端口复用配置完成后,在PC端进行ping命令。再来查看nat映射表。

Router#show ip nat translations

原文链接:https://www.idaobin.com/archives/510.html

既然都复制粘贴转载了,就不能打赏一点…ヘ( ̄ω ̄ヘ)

支付宝 ——————- 微信
图片加载中图片加载中

发表评论

电子邮件地址不会被公开。 必填项已用*标注

46 + = 56